Return to the Orchids Forum | Post a Follow-Up

 o
Cattleya orchid white huge brown spot help please

Posted by rwood24 North Carolina (My Page) on
Fri, Jun 11, 10 at 19:36

Ok I'm posting this again cuz I beleive my first post was too long sorry. Ok I have a store bought white cattleya orchid. Purchased in bud(no blooms) 4 buds. One bloomed for 3 days the other three yellowed and fell off, now I've noticed a huge brown spot a pic link is below, I have recently repotted hoping it'll help. Should I cut the shoot off? BTW I've grown dendros and phals with ease my setup is two 50 watt cfls and one vertical t5 20 watt . I treat the cattleya like my others please help I'm worried it won't survive. Thanks ryan

Here is a link that might be useful: Brown spot on White cattleya orchid


Follow-Up Postings:

 o
RE: Cattleya orchid white huge brown spot help please

I can't tell anything from the pic. On my monitor it looks like a healthy plant. A huge brown spot could be what I just removed from a catt; it was a sunburned leaf. If you've just repotted, I'd not disturb the plant further. Is there new growth started?


 o
RE: Cattleya orchid white huge brown spot help please

You didn't need to shorten your post - the problem is the photo. If you can get a better picture we could advise you better. Try for a close-up of the spot.

Jane


 o
RE: Cattleya orchid white huge brown spot help please

Sorry guys! New to computers haha.

IMG_0854.JPG

maybe that copy and paste works if not try link below please and click on pick if enlarge is needed. Someoneone ask on old post if it was mushy nope it isn't and color is lighten a little more light brown. I've not seen any signs of new growth yet either. Thanks to all

Here is a link that might be useful: Larger pic yay!! Hopefully atleast on mine it is


 o
RE: Cattleya orchid white huge brown spot help please

I bet it's a burn and can be ignored


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Orchids Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here