Return to the Perennials Forum | Post a Follow-Up

 o
amsonia hubrichtii

Posted by nancy0903 10 (My Page) on
Tue, Jul 22, 14 at 12:20

My amsonia looks like it's struggling. It has lost it's leaves on lower branches. It has been in the same spot- part sun, well drained soil. I don't see any insects on it. Any ideas?
Thanks


Follow-Up Postings:

 o
RE: amsonia hubrichtii

Amsonia hub. needs full sun and space. Mine were in too much shade, crowded and were thinning. A move to full sun solved the problem.


 o
RE: amsonia hubrichtii

Thanks. Maybe I'll move it in the fall. It is leaning towards light although I thought it got enough!!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Perennials Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here