Return to the Perennials Forum | Post a Follow-Up

 o
Coneflower 411 please

Posted by mxk3 z5b/6 MI (My Page) on
Fri, Jul 27, 12 at 22:15

My newly planted "Pow Wow White" were smashing. Note the "were". I was out putzing the other evening and noticed some dead branches on two of the four plants. I'm wondering if coneflowers don't like moister soil - I had sprinklers put it about a month ago and stlll trying to figure out the best watering schedule. I'm not really sure that's the problem, but it's the only think I can think of that is out of the ordinary. I put my finger into the soil, and it was moist, but not wet, but I'm not sure how moist is too moist for coneflowers - ? .


Follow-Up Postings:

 o
RE: Coneflower 411 please

If the rest of the plant looks healthy, check for stem borers in the part that died.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Perennials Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here