Return to the Roses Forum | Post a Follow-Up

 o
Thrips

Posted by Tweety101 10 (My Page) on
Fri, Apr 4, 14 at 12:03

I have noticed that my rose bush has very healthy leaves but the blooms don't look so great. The petals and turning brown before it has fully bloomed. I have done some research and I was wondering if Thrips were the cause of this problem. Or does anyone have any other ideas? If it is thrips are there any natural ways to get rid ofthem?
Thanks!


Follow-Up Postings:

 o
RE: Thrips

  • Posted by seil z6b MI (My Page) on
    Fri, Apr 4, 14 at 12:23

Yes, it could be thrips. Could also be botrytus. Can you post a picture? That would help.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Roses Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here