Return to the Antique Roses Forum | Post a Follow-Up

 o
Rosa mundi

Posted by Llanwenlys 8 (My Page) on
Thu, Jul 21, 11 at 11:38

My Rosa Mundi (two years old) has bloomed for the first time. I got it from High Country Roses.

I expected a striped, variegated rose, but this is one solid color, all fuscia-deep pink.

Why? Any ideas?


Follow-Up Postings:

 o
RE: Rosa mundi

It's reverted to the Apothecary Rose. It will do that. Mine is often part one, part the other.


 o
RE: Rosa mundi

My Rosamundi is also in its second year. The beginning of the spring bloom cycle was striped as expected. However, now there are approximately 4 blooms and all are solid pink.
We recently had a major wind storm and I wonder if the trauma caused by the wind caused the reversion?
Jeannie


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Antique Roses Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here