Return to the Shrubs Forum | Post a Follow-Up

 o
Arborvitae help please

Posted by DesertFarmer 7a (My Page) on
Mon, May 7, 12 at 21:03

Hello all, I came across your forum and hoped you could help me with a arborvitae problem I've been having.

Im in the Reno area, zone 7a and I have about 10 arborvitae and ever since winter they have started to turn brown and dry up. These plants should be about 4-5 years old and its not the entire plant that is turning brown but just branches. I water it every day but I do not know what might be causing this, if anyone has had this problem before I would really appreciate any advice of info :)

Photobucket

Photobucket

Thank you!


Follow-Up Postings:

 o
RE: Arborvitae help please

The arborvitae have only been doing this for the past 6 months or so, no positive improvements so far, just more brown and more dryed out crunchy leaves


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Shrubs Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here