Return to the Shrubs Forum | Post a Follow-Up

 o
Red Chokeberry

Posted by mainegard3 5 (My Page) on
Sun, Oct 10, 10 at 8:53

I have a new red chokeberry that is doing well that was planted in the summer. The weather in maine was dry and hot. In late september the 20 or so leaves it had, some turned red but not a real show. Now the leaves are all gone. Should I expect more of a show as everyone has mentioned once the shrub matures and has more leaves? I guess I wasn't expecting premature leaf drop considering many leaves were still green.


Follow-Up Postings:

 o
RE: Red Chokeberry

I forgot to mention that there were a few berries on the shrub that never turned red. Now they are gone. Again, I suspect the shrub is not esablished yet.


 o
RE: Red Chokeberry

  • Posted by bboy USDA 8 Sunset 5 WA (My Page) on
    Sun, Oct 10, 10 at 10:49

Implication is it got dried out.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Shrubs Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here