Return to the Tool Shed Forum | Post a Follow-Up

 o
Homelite UT8010B Primer Bulb

Posted by jrtmouse CA, USA (My Page) on
Wed, Jan 27, 10 at 0:28

Homelite Blower (UT8010B) primer bulb is busted which probably explains why it won't start. I've found three different replacement bulbs online but not sure which model the carburetor is. They fit Walbro carburetors but there are several different model numbers of carbs (HDA, WZ, WA, etc...). Anyone have any ideas where I can find these letters on the carburetor? OR perhaps someone has this model of blower and could share this information?

Thanks!


Follow-Up Postings:

 o
RE: Homelite UT8010B Primer Bulb

  • Posted by canguy British Columbia (My Page) on
    Wed, Jan 27, 10 at 9:34

The letters are quite prominent on Walbro carburetors. If a Zama, you will need good eyes or glasses to see them.


 o
RE: Homelite UT8010B Primer Bulb

Unfortunately, I've been unable to locate these prominent letters on the carburetor. I can clearly see where WALBRO is but nothing more. Where would I find the model numbers in regard to "WALBRO"? Should they they be on the same side? On the back side...that is not so accessible? If you would point me into the right direction, I will look for them.

Thank you!


 o
RE: Homelite UT8010B Primer Bulb

  • Posted by canguy British Columbia (My Page) on
    Sat, Jan 30, 10 at 12:42

Take the bulb to a small engine shop, most should be able to match it up. Homelite only offers a complete carb replacement, no repair parts.


 o
RE: Homelite UT8010B Primer Bulb

I was able to take the bulb into a local mower shop and they were able to sell me a new bulb for about $5. We're up and running now!

Thanks for the advice! Sometimes I think I'm so confident that the internet will provide what I need, I forget about local shops and sometimes they really are easier.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here