Return to the Tool Shed Forum | Post a Follow-Up

 o
craftmansnow blower

Posted by djb218 MN (My Page) on
Sat, Feb 15, 14 at 14:58

My Craftsman 30" (model 247.8830) :
My son did not clean out the ice before starting it but when he did it would not throw snow. Discovered there were 2 sheer pins that needed to be replaced.
The front augers are spinning constantly while the back augers are working fine. No snow is being blown out. Thanks for any help.


Follow-Up Postings:

 o
RE: craftmansnow blower

  • Posted by baymee LehighValleyPA (My Page) on
    Sat, Feb 22, 14 at 7:00

Not a valid model number. Not enough info to answer with.


 o
RE: craftmansnow blower

247 is MTD, but there should be 6 digits after the decimal point.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here