Return to the Tool Shed Forum | Post a Follow-Up

 o
Honda FG100 Mini Tiller

Posted by mangy-dog none (My Page) on
Sun, Apr 3, 11 at 10:29

My FC100 tiller is 5 years old. It is used 1 hour per year and is drained of fuel and run dry after each use. It starts fine, idels fine and works fine for the first ten minutes of use. After ten minutes, it loses all power to the point it no longer runs. Any ideas? I would appreciate the help.


Follow-Up Postings:

 o
RE: Honda FG100 Mini Tiller

I always try the easiest fix first, so I would clean out the gasoline tank and replace the fuel filter (page 26 in owner's manual.)


 o
RE: Honda FG100 Mini Tiller

just fixed this exact issue. Download the owner manual and do the transmission service. This is supposed to be done every 25 hrs or once each season.

Trust me, same issue and I serviced the tranny ... works fine!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here