Return to the Tool Shed Forum | Post a Follow-Up

 o
Tecumseh engine issue

Posted by ashtonw25 none (My Page) on
Mon, Apr 28, 14 at 15:39

Hello,
I recently bought a rotavator, it has a Tecumseh Prisma 37 engine. When it came all of the linkages on the throttle were in the wrong place so i changed them according to diagrams on the internet.

The problem i have now is that the engine will not rev at a reasonable speed. Its revs very high and if you close the throttle slightly the revs fall sharply and it stalls. The opposite for increasing the throttle, it rises very quickly to a very high rate.

I have adjusted the limiting screws and seemed to have tried many different set ups all with the same result.

Has anybody else had this problem or does anybody know how to fix it?

Many Thanks

Will


Follow-Up Postings:

 o
RE: Tecumseh engine issue

1. Please show a good close picture of your linkage setup.
2. A picture or link to the Internet setup.
3. This will give those familiar a view to share what works best for them.


 o
RE: Tecumseh engine issue

Is the connection to your governor shaft tightened?


 o
RE: Tecumseh engine issue

Since adjusting the HI and LO limits screws does not help.

Check the throttle "rod" where it attaches to the throttle plate. I have no clue as to the proper name for the parts. But it is the part that the red arrow points to. Where the rod attaches to the plate. The connection is just pressed tight and flared over like a rivet. Wear over time can cause the two parts to separate causing the throttle to go nuts and impossible to adjust correctly.

One way to check and repair the parts is.
Remove the carb.
Hold the throttle plate in the closed inside of the carb.
Try to work the plate on top of the carb and look for any play between the two parts.
If you find excess play. Hold the throttle plate closed in the carb and the plate on top of the carb in the closed position.
Mark the two parts where they should be. AWL works good for this.
Remove the screws that hold the plate inside of the carb and pull the rod out through the top.
Clean the parts good, align the marks and Silver solder using flux the two together. (Turning the two upside down prevents the solder from running down the rod).
Reinstall the throttle plate and the carb to the engine and try again.


 o
RE: Tecumseh engine issue

  • Posted by baymee LehighValleyPA (My Page) on
    Thu, May 1, 14 at 14:50

You don't say anywhere that you adjusted the governor arm and stem properly. Did you?


 o
RE: Tecumseh engine issue

Hello,

Thanks for the replies.
The linkages are in place exactly the same as in the picture.
There is a possibility i have not adjusted the governor arm properly, could you give me any advice on how to do this?

I will look to see if there is wear between the throttle plate and top plate. Thank you for the suggestion.

Kind regards

Will


 o
RE: Tecumseh engine issue

  • Posted by baymee LehighValleyPA (My Page) on
    Sat, May 3, 14 at 7:41

If you removed the arm, then you have to readjust the governor. If not, then no.


The arm is on the right of the pic and the springs attach to it. Loosen the screw that tightens the arm to the small shaft that comes out of the engine so that it doesn't turn the shaft.

Tecumseh engines:

Rotate the governor shaft counterclockwise as far as possible on vertical crankshaft engines or clockwise on horizontal crankshaft engines and hold it there. At the same time, move the governor arm until the carb throttle shaft is in the wide open position. Then tighten the governor shaft screw, making sure you held the shaft in the proper position.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here