Return to the Tool Shed Forum | Post a Follow-Up

 o
Echo Trimmer

Posted by ichabod z8GA (My Page) on
Sat, Apr 13, 13 at 17:52

Working on an Echo GT-2000 string trimmer. Rebuilt the carb last season and it was running good then. Now it won't fire. Tried a new plug and tried a small amount of fuel straight into the throat of the carb. Compression is 125 psi. Also regapped the coil to 0.07 inch. The spark will jump a 0.25 inch gap, but very weak and yellow compared to my Stihl trimmer. I'm inclined to replace the coil but not sure if the cost is worth it because I don't know what a new, equal trimmer would cost. The 2000 must be an older model. What would you do?

Ichabod


Follow-Up Postings:

 o
RE: Echo Trimmer

Oops, should have been 0.007 inch gap.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here