Return to the Tool Shed Forum | Post a Follow-Up

 o
Stihl Chainsaw Problem

Posted by kenmist8193 NC (My Page) on
Fri, Apr 9, 10 at 21:41

Have a Stihl 170 that probably has less that 2 hours use. Only filled it with gas twice and it has run well. Now when I start it it runs at one speed. The gas trigger has no effect on the engine speed and the chain doesn't move with the "brake off"? I have checked the gas and bar oil tanks and both are filled. Any suggestions?


Follow-Up Postings:

 o
RE: Stihl Chainsaw Problem

  • Posted by canguy British Columbia (My Page) on
    Fri, Apr 9, 10 at 21:46

The throttle link has likely fallen off the trigger or carburetor.


 o
RE: Stihl Chainsaw Problem

Like canguy said, take it back to the dealer to get fixed. On Stihl saws with the one lever choke and switch it's good to hold the throttle open when going to full choke. Steve


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here