Return to the Tool Shed Forum | Post a Follow-Up

 o
Ryobi Weed Trimmer Line Problems

Posted by jeff_eber IL (My Page) on
Thu, May 18, 06 at 0:14

I own a Ryobi Weed Trimmer, gas powered about 3 years old. The model number is 725R. It is the model that has a few different attachments that can be used with it. I have the weed trimmer and blower attachments. My problem is this: The trimmer line always spins (slips) back into the head which forces me to shut the unit off, unscrew the head and the re feed the trimmer line into the head and wind it up again. This happens everytime I use this thing. I have the right size diameter line and am following the line installation directions exactly as stated. I'll be trimming along and will let the trimmer idle for a moment while walking to another part of the yard and when I rev the engine to start trimming again the line disappears into the head. I can not bump feed this unit either. I spend more time re loading the line than I do trimming. Is this happening to anyone else, or is it just me? I don't get it. If you know of a way to keep the line from doing this, or a replacement head that will not do this, please let me know. Thanks,
Jeff


Follow-Up Postings:

 o
RE: Ryobi Weed Trimmer Line Problems

Jeff one thing I have noticed about my Ryobi trimmer is that if any weeds get wrapped around the shft it pushes the head down towards the nut and the spool doesnt lock into place and the automatic feed doesnt work. I have to occasionally stop and clean the shaft off above the head. If that isnt a problem then Im not sure what the answer is.


 o
RE: Ryobi Weed Trimmer Line Problems

I also had - note past tense - the same problems with my Ryobi "Grass Scopion" line trimmer Model RCT2800A.
I got so frustrated with the line spooler/head problems that, after a few years, I would have rather used a pair of hand shears to do the lawn edging!

Considering that 2-stroke engines are pretty good now-a-days, I would argue that the trimmer head is the most important functional part of a line trimmer.
And when you look around at the variety available from the major line trimmer manufacturers you start to appreciate why the heads fitted to Ryobi's entry
level models do not function properly... i.e. they were designed with only one criteria in mind: cost of manufacture!

However there are some very good trimmer heads available that ARE designed to do the job, e.g. from Stihl et. al.
But if you don't what to go out and but a Stihl you can get an aftermarket head for your Ryobi.

When looking for the leader* in 'design', the number of patents taken out is generally a good indication and, going by the number of patents taken out by Ryobi,
they are not up there with the leaders.
*A Mr. Richard A. Proulx, of "Proulx Manufacturing Inc." seems to be a leader in this field. Check out his latest patent application here:
http://appft1.uspto.gov/netacgi/nph-Parser?Sect1=PTO2&Sect2=HITOFF&p=1&u=/netahtml/PTO/search-bool.html&r=1&f=G&l=50&co1=AND&d=PG01&s1=Proulx.IN.&s2=%22Richard+A%22.IN.&OS=IN/Proulx+AND+IN/%22Richard+A%22&RS=IN/Proulx+AND+IN/%22Richard+A%22

I ended up buying a good aftermarket head for AU$50, and it's made in Australia to boot.
Since then I have only felt the need to curse the Ryobi when the line runs out or when it goes out of tune**.

**Another problem I had to fix on the Ryobi was a sticky throttle. Initially I thought it need a tune up because I didn't have the throttle control I expected
(the engine was running at nearly full speed most of the time). While attempting the tune-up I discovered that it was actually the throttle trigger that was sticking...
After removing the covers I discovered that there was no clearance between the plastic trigger (where the throttle cable connects to it) and the main shaft of the trimmer.
Grinding away a mm or so off the shaft with my Dremell did the trick and I managed to tune it quite niceley as well :)

Lampet


 o
RE: Ryobi Weed Trimmer Line Problems

I have several Ryobi trimmers. The line feed mechanism works fine with the standard line.

It almost sounds like you have your line wound backwards. Think about it - it goes back into the head and you can not use the bump head.

Just try reversing the direction of how you wind it.


 o
RE: Ryobi Weed Trimmer Line Problems

A TV garden guy suggested spraying the spool with vegetable oil.


 o
RE: Ryobi Weed Trimmer Line Problems

I should have mentioned that the original trimmer head on my Ryobi "Grass Scorpion" was of the single spool type, and that the aftermarket one has a split spool.

With the Ryobi (single) spool, I always made sure to wind on the (paired) lines in the direction of the arrow that was moulded into the plastic and always kept the total length of line less that 2 metres (i.e. 1m for each side) in an attempt keep the wound spool as tidy as possible. In operation however, tangles inevitably occurred on the spool.

In any case, it always seemed to me to be very optimistic to expect two lines - wound on as a pair onto a single spool - to feed out smoothly through the opposing exit ports of the head without ever crossing over each other and creating a tangle.

If you have a split spool in the head of 'your' Ryobi and you are winding the line on in right direction (as marked?), then it should feed the line out at least as good as my aftermaket split spool type.

Lampet


 o
RE: Ryobi Weed Trimmer Line Problems

I have had this issue as well. Thanks for all of the very good suggestions. Unfortunately, I still had the same issue where the line simply would not spool out. So, I spent awhile looking at the thing, and this is the solution I came up with that works for me:

The bump knob screws into the spool assembly with a reverse thread screw. The screw is held into the bump knob with a washer that seats into the plastic inside the knob. There is a bit of slop because of this, which in my case meant that the bump knob screwed down too tight onto the assembly. And that prevented the spool from moving inside the casing.

Solution: Unscrew the bump knob and add an extra washer to the bolt (one should do it, but you may need two) Works like a charm now.

Also my 2 cents on winding the line: make sure the line is wound on the spool fairly tightly, and try to make sure the pair of lines stay together. That should help prevent the line from getting bound up in the spool.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here