Return to the Tool Shed Forum | Post a Follow-Up

 o
irrigation query

Posted by strobiculate none (My Page) on
Sat, May 19, 12 at 10:06

anyone have any experience with Berkely irrigation pumps?

we have one with a kawasaki 8hp motor. motor works fine. pump primes (protek #4 hand primer) (cheap s.o. who doesn't have to use it...yeah)...at any rate...if i take the outlet tube off the pump primes and water gushes forth. i feel like moses striking a rock. however that doesn't get water from the pond to the veggiez. if i put the outlet pipe on, it doesnot prime.

????


Follow-Up Postings:

 o
RE: irrigation query

Take outlet pipe off drain all water out so pump push air out freely make a check that there no kinks in pipe 2 are 3 psi backpressure will stop prime.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here