Return to the Tool Shed Forum | Post a Follow-Up

 o
Craftsman Pressure Washer has no pressure

Posted by 60thjeep none (My Page) on
Thu, May 26, 11 at 11:40

I have tried to do a lot of research and tinkering with this, but thought maybe I am missing something.

I had an original problem of the washer surging high to low pressure, but now after installing a new unloader all I get is low to very little pressure on low pressure and when I switch the nozzle to high pressure all I get is a fine mist. I also replaced the wand and nozzle and this didn't help.

Model #580761800

Any ideas?

Thanks


Follow-Up Postings:

 o
RE: Craftsman Pressure Washer has no pressure

I messed with one of those, a gift from somebody, in the trash, but never got pressure up, so now, it has been waiting for 2 years for me to come get it out of the trash dump! I know, not much help. Folks have complained about that problem, but i never got one to work again.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here