Return to the Tool Shed Forum | Post a Follow-Up

 o
Merry Mac Woodchipper 6.5 hp

Posted by notaplumberbychoice none (My Page) on
Mon, Jun 25, 12 at 1:47

I bought a used Merry Mac woodchipper. After using the chipper for about 3 hours, the steel started to crack. Fresh crack on the loading shoot. Any ideas why this would have happened and how to prevent the steel from cracking further?


Follow-Up Postings:

 o
RE: Merry Mac Woodchipper 6.5 hp

Please post a picture of the weld needed. Depending on the thickness of the material a weld is not always the best solution IMO.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here