Return to the Tool Shed Forum | Post a Follow-Up

 o
GC160 mystery part

Posted by zeke7237 CT (My Page) on
Wed, Jun 18, 14 at 9:09

My old reliable Excel power washer with Honda GC160 broke a timing belt a few days ago. I finally got the pump off and the case opened, and I found an odd part in the bottom of the case. I can't find this in any of the breakdown diagrams, and it appears to be broken .. anyone have any idea?


Follow-Up Postings:

 o
RE: GC160 mystery part

Never mind .. it's from the cam assembly! My cam flew apart last year and this piece evidently broke off and dropped into the case ..


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here