Return to the Tool Shed Forum | Post a Follow-Up

 o
Pressure Washer: Troy built

Posted by sgcruz Florida (My Page) on
Tue, Jun 15, 10 at 20:48

Bought Troy Built Pressure washer (2550 PSI) 13 months ago. Has worked perfectly up until now. This time, the water comes out when you pull the trigger, but it's got the pressure of a garden hose at best.

We have kept this in the garage and it has only been used 5-6 times. Never put any bleach (or any chemicals at all)in it. The box store were we bought it says it is probably the pump and it would be cheaper to replace the pressure washer than to fix the pump(of course). Any ideas? Any chance it's something other than the pump?


Follow-Up Postings:

 o
RE: Pressure Washer: Troy built

  • Posted by canguy British Columbia (My Page) on
    Wed, Jun 16, 10 at 0:36

The unloader in the pump is stuck, a common problem. It may or may not be repairable. Can you post the model number/


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here