Return to the Tool Shed Forum | Post a Follow-Up

 o
Sprayer not working

Posted by swflagrdnr 10 (My Page) on
Mon, Jul 30, 07 at 10:10

Hi:

I bought a one gallon handheld sprayer - the kind you fill with whatever (Roundup in my case), pump the handle to build pressure and use the wand/handle to dispense. It cost about ten buckns, new at the box store. The problem is, it stinks.

I adjusted the wand tip so that the liquid leaves as a spray or heavy mist. When I squeeze the trigger on the wand, it flows quite well for about 2-4 seconds. Then the mist/spray stops and I get a drip or two. If I release the handle and wait, I dunno, 5-10 seconds before pulling the trigger again, the mist/spray returns. It almost seems like the pressure needs to "re-build" in the tank. But that doesnt make any sense. Im a big guy and I pump the tank up tight. there is LOTS of pressure still in the tank when I do this. I know because the first time or two I unscrewed the tank lid (the contraption that contains the pump handle) and when I did there was a massive WHOOSH! and lots of ait and Roundup sprayed up at me from around the lid gasket. So, pressure in the tank is not my problem.

Any ideas?

Like I said, if I wait a few seconds, then pull the trigger again, the mist pressure is back, but just for 2-4 seconds. What is wrong with this thing?

Thanks


Follow-Up Postings:

 o
RE: Sprayer not working

  • Posted by canguy British Columbia (My Page) on
    Mon, Jul 30, 07 at 10:14

For some reason, the liquid is not atomizing and the nozzle is clogging. It may be a design fault.


 o
RE: Sprayer not working

I will have to check this. I dont know what could be clogging it as I never ran anythin biut liquids through the thing.

I should clarify something. If I compeltly loosen the tip at the end so that the liquid comes out in a stream, not a spray, the same thing happens. It comes out forcefully for 2-4 secomnds, then drips. Then nothing. If I let up off the trigger for 5-10 secs, it seems to "re-charge" then work okay again. This to me sounds like its not a particular clog. I will check, howver.


 o
RE: Sprayer not working

CHEAP SPRAYERS ARE PRONE TO THIS. i bought a couple cheap ones and the wand was the problem. if you have access to another sprayer, swap the wand with ti to see if the problem persists. usually the hose will unscrew fromt eh base of the wand allowing you to change the entire wand, valve and all. lowes and wally world sell replacements, but get a good one!


 o
another thing

some sprayers have a bladder inside, you pump up it fills the bladder with a couple ounces of fluid. you spray it empties the bladder. then once you quit spraying it refills the bladder. i wonder if this is not your problem.

remove the pump and look into the tank. if the hose goes all the way to the bottom of the tank, then this is not it. but if there is a seperate chamber the hose goes in, this is your issue and you need a new sprayer.


 o
RE: Sprayer not working

I'd take the hose off the tank and look for an obstruction inside the "barbed" fitting. Blow back toward the pick up.
There has to be a severe restriction somewhere between the pick up tube and the valve.
It allows the hose to slowly pressurize between the clog & valve.
Is there a "screen" of some type on the end of the pick up tube?


 o
RE: Sprayer not working

  • Posted by canguy British Columbia (My Page) on
    Wed, Aug 1, 07 at 10:00

I hope you were wearing protective clothing when you got the bath. Roundup is a non selective herbicide and quite potent, not good to breathe or absorb through the skin.All garden chemicals need to be handled carefully. As was suggested earlier, ante up for a good sprayer, they are less than 50 bucks.


 o
RE: Sprayer not working

RU won't hurt you unless you drink a large quantity. at household mix levels it won't even harm sensitive skin. even at 41%, the uncut concentrate, it rarely if ever has caused any skin irritation other than making you sticky when it dries.

yes, it should be handled properly, but there is no need to try to scare people.


 o
RE: Sprayer not working

Sounds like there is some small particle in the valve. Try blowing out with air compressor. Whenever you have to replace the sprayer bite the bullet and lay out about 40 bucks for a Solo. Top quality and it has a inlet valve like a tire valve on the side where you can pressure it up with your compressor and it will spray the entire 2 and a half gallons without ever pumping the handle. Comes with several spray nozzles too. I used to buy a new cheap sprayer every year till I bought the Solo about 5 yrs ago.


 o
RE: Sprayer not working

  • Posted by canguy British Columbia (My Page) on
    Fri, Aug 3, 07 at 9:39

David, it was not my intent to scare anyone. Just warning him to be careful. I worked with RU in large scale spraying operations by helicopter and we handled it carefully, even diluted.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here