Return to the Tool Shed Forum | Post a Follow-Up

 o
McCulloch Chain Saw

Posted by redrabbit Pgh Pa (My Page) on
Sun, Jul 7, 13 at 14:39

This saw will only run and start on starting fluid.There is no sign of fuel in the primer bulb when pushed.Model CS 38 EM , Ser # 110501. Saw ran good before ?? Thanks


Follow-Up Postings:

 o
RE: McCulloch Chain Saw

What have you done related to finding the problem? Such as:

1. Disasemling, inspecting and cleaning the carb for restrictions all ports/screen, bad diaphragm and etc.

2. Replacing all fuel lines, primer bulb, fuel filter and clean fuel tank if needed.

3.You should see some fuel in the bulb and see it moving while pumping or that's restriction IMO.

Good Luck!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here