Return to the Tool Shed Forum | Post a Follow-Up

 o
Walbro Carb WT-685

Posted by homegrown55 9 (My Page) on
Tue, Sep 28, 10 at 18:02

The WT-685 is on a Troy Bilt TB90BC brush cutter with external purge/primer bulb. Machine starts up and idles great. New fuel lines, new plug, cleaned carb (sprayed with non-chlorinated brake cleaner and WD-40). Decarbonized engine and muffler. Fuel filter clear. Checked ignition air gap (ok). Problem is...will not accelerate, at all. Feathering the throttle only raised the rpm's very little. So...is it 1. bad diaghragms and/or fuel pump (it has the blue one) or 2. Just need to tweak the high or low mixture screws (D- shaped heads)? Before all this done, machine would NOT start, but starts right up now. Thanks.


Follow-Up Postings:

 o
RE: Walbro Carb WT-685

Home: You have a 3rd Generation Walbro-WT . I would 1st remove all jets and spray concentrated carb cleaner not brake cleaner with the carb circuits. Ensure to remove Inlet and Metering Valve needles and also clean the venturi with carb cleaner. Refill with fresh fuel mix with 2 ounces of carb cleaner and you should be fine . The diaphragm on these carbs are quite substantial . If you see a small tear or stretching of the diaphram then you may have to replace but I have not seen one yet that was in need of replacement even with ethanol based fuels .


 o
RE: Walbro Carb WT-685

I appreciate the reply. So, you are saying, just do a more thorough job of cleaning the carb ( I used a weaker cleaner because I don't want to weaken or damage the check valves)?
The blue fuel pump diaghragm looked pretty sturdy (admit I didn't check how pliable the flaps were) and the metering diaghragm looked to be in good condition (not brittle). Your consensus then is that there maybe is trash in the carb (needle-seat area and/or high and low speed circuits? I have some Chemtool cleaner and some Sea Foam..have a fresh mix of fuel a few days old w/newer, improved Stabil in a half gallon. I still want to know the exact cause of the non-acceleration issue. I will try these remedies..posting back with results. Thanks.


 o
RE: Walbro Carb WT-685

Yes it would be most common a fuel restriction than a Obvious Throttle Component Malfunction (broken linkage) which you would most likely have identified . It would appear that the Idle and Primer Secondary Circuits are clear but the Main Fuel Circuit is obstructed by debris , varnish restricting the fuel delivery off idle . You do not indicate how long the unit has been stored since it's last usage or fuel condition (life cycle). Most fuel will begin to breakdown within 30 days . If you are currently using a Ethanol based fuel then gumming of the fuel circuits and weakening of the diaphrams (stretching) can occur over time. Be careful when removing the diaphrams not to damage (tear or further stretch) them. Be patient in some extremely stubborn cases the carb body requires a overnight rinse in carb cleaner / conditioner. 1st try KISS approach I 1st advised of giving the fuel / cleaner mixture 30 minutes to begin working prior to attempting starting . Once started let it idle until it begins to clear out the varnish / gumming . If this fails go to the overnight soak scenario with diaphrams removed. Good Luck and Keep us Posted Bro !


 o
RE: Walbro Carb WT-685

The problem with the carb has been resolved. Took the carb apart including the jets and needle and liberally sprayed into it with high pressure carb cleaner. Found some very small debris afterwards in the metering chamber cavity. Adjusted the L and H screws about 1 1/2 turns out from light seat and it started (again). After very little tweaking it now throttles up great and still idles great. Added 1 oz of Berryman B-12 to the 1/2 gallon of new fuel which has stabil and is at the most 10% ethanol. I think you were correct EWALK in assuming a more thorough cleaning was needed. Don't know the length of set-up period but do know what it causes! Friend's brush-cutter. Thanks for the input and getting involved...good help is VERY hard to find these days. I'm doing a Ryobi with a Walbro w/limiter caps on it now (it's a hobby...not a job!)


 o
RE: Walbro Carb WT-685

Home: Glad to here all is Good . The Berryman addition in the fuel mix every yr on Start-up is a sound investment along with the Stabil during Storage . Welcome to the Forum and Happy cutting Dude !


 o
RE: Walbro Carb WT-685

Homelite chain with same carb. I prime it and it runs till the prime is done then quits. I replaced all the fuel lines and installed carb. kit. Same result. Any ideas? Thanks.


 o
RE: Walbro Carb WT-685

If you're having the non-acceleration issue, then I suggest you try opening up the L-speed mixture screw on the carb screw closest to engine) about 1/8-1/4 turn. I removed the L and H screws on mine and cut slots in the heads. That usually does the trick if everything else on the carb is OK. Here's a tune up guide:
http://tech.flygsw.org/walbro_tuneup.htm
Here is a WT carb parts breakdown (if ya need it)
http://tech.flygsw.org/walbro_tuneup.htm
I hope you remembered to put the metering lever diaghragm on top of the gasket with the gasket on the carb body first and not vice-versa. Easy mistake to make. Post back if you need to.


 o
RE: Walbro Carb WT-685

Atta Boy Homegrown55 Cudo's ! :)


 o
RE: Walbro Carb WT-685

Due to my negligence, I am reposting the link that shows the wondrous Walbro WT model carburetor parts diagram.
Here is the correct link:
http://wem.walbro.com/distributors/servicemanuals/WTseries.pdf


 o
RE: Walbro Carb WT-685

I own a troy bilt trimmer with this carb. Mine was not accelerating at all. When I attempted to set the idle up I accidently broke the idle screw assembly off the metering cover. The part no. on the carb is WT685, but when I search for a replacement by that number, I can't find one; not even on the Walbro website. Does anyone know if this carb is discontinued and what the replacement number is? thanks, sandersjm


 o
RE: Walbro Carb WT-685

Hi sandersjm I hope this helps you!

http://wem.walbro.com/walbro/product2.asp?Series=WT&partnum=WT-685-1


 o
RE: Walbro Carb WT-685

After re-evaluating sandersjm's post; it may be necessary for you to install a Gasket and Diaphragm Kit. They are relatively cheap and VERY easy to install. There is also a full rebuild kit available. My experience shows the non-acceleration issue due to misadjusted Low Speed Mixture needle OR a dried up fuel pump diaphragm. The kit has the new fuel pump. They do dry out along with the metering diaphragm ( has little metal tab on it). The G & D kit has those items and usually corrects the non-acceleration issue. The G & D Kit for the Walbro WT-685 is D10-WAT. Your parts diagram page shows this kit number and the full repair kit.
These kits are readily available for sale on Ebay.


 o
RE: Walbro Carb WT-685

1. I have had a Walbro kit since the 90s that served many brands of equipment.

2. I have seen these fuel filter screens with all types of restrictions and easy to check.

3. The screens have not been fun to replace, which means I clean and verify it’s clean.

Hello ewalk!


 o
RE: Walbro Carb WT-685

Absolutely! A fuel restriction cause by that little fine mesh screen has to be cleaned. If a user had their fuel lines deteriorate or has had that carb in service for an extended amount of time; then chances are more than likely it needs to be cleaned. That was a great point to bring up.


 o
RE: Walbro Carb WT-685

My problem with installing the new fuel inlet screens is they are not preformed or started to form vs flat. A tech told me to use a pencil’s erased or etc to press it in but I never mastered installing vs cleaning. Some in-tank fuel filter can be almost totally restricted due to not cleaning around the fuel cap before adding fuel or etc..

It is hard to believe what you will see in some fuel tanks. Those are the ones that I w/n touch even for extra money. You have to accept some responsibility if you expect your equipment to run.


 o
RE: Walbro Carb WT-685

Hey HG and Loger Quite an old thread lol . The 2h pencil with eraser end is the easiest way to preform and install the fine mesh inlet needle prefilters that I have utilized un the past . I had a pair of Walbro WD that I used to replace Kehien on my Polaris Starfire 650 back in the mid seventy's . Wow that s really showing my age . Actually they were quite a good Diaphram pump unit prior to Mikuni Slide carbs dominating the scene. Have been enjoying the new RV and catching plenty of walleye lol . Take care all :+


 o
RE: Walbro Carb WT-685

Hi ewalk I see recent times have been pretty good to you! Good for you too! Just trying to help the latest poster to this thread get things straight here: sandersjm. If ya noticed he had some inquiries about a Troy Bilt with the Walbro WT-685 like the one I fooled with a few years back. Thanks to posters like you and others on here; I have learned quite a bit since then. Mind ya though, a LOT of it was trial and error! Enjoy the fishing man!


 o
RE: Walbro Carb WT-258

I rebuild this carb and everything is set right but when you press primer bulb it floods real bad, what have i overlooked..thanks


 o
RE: Walbro Carb WT-258

I rebuild this carb and everything is set right but when you press primer bulb it floods real bad, what have i overlooked..thanks


 o
RE: Walbro Carb WT-685

I don't know what you are fueling with this carburetor. The metering diaphragm may be installed wrong (up against the metering lever instead of on top of the gasket). The gasket goes on the carb first, then the metering diaphragm (has little metal tabs in middle). The side that looks like a spoke goes face down on top of gasket. If it pushes down TOO much or all the time, the carb can flood. The lever controlling fuel needle setting is adjustable, you just need a straightedge to set it by bending it.
Another cause of flooding could be the Low and./or High Mixture screws(needles) are OPEN too far. A good initial setting for them is is about 1/1/4 to 1 1/2 turns out from lightly seated. A bad check valve on top of the primer base assembly( the plate under the bulb) may contribute to flooding also.
Make sure the routing of your fuel lines is correct. The Walbro site can be of some help here also.

Here is a link that might be useful: Walbro Service Manual

This post was edited by homegrown55 on Tue, Oct 1, 13 at 13:29


 o
RE: Walbro Carb WT-685

Re flooding: I was reinstalling an external primer bulb to my chain saw carb and got things backwards which caused huge flooding. Loger set me straight with a video about primer bulb hookup. Perhaps you did the same thing? The external primer bulb is attached to the outlet of the carb and pulls fuel thru the inlet. The bulb then expels fuel back to the gas tank.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here