Return to the Tool Shed Forum | Post a Follow-Up

 o
Craftsman Dual Stage Snowthrower Auger noise

Posted by ronoman7 PA (My Page) on
Sat, Dec 7, 13 at 0:11

Have a older Craftsman dual stage snow thrower (approx. 1995) that when disengaging the auger, it makes a brief screeching noise until the auger stops. the front and internal augers both work fine with no noise while engaged and spinning. belts are in good condition. just makes the noise when I release the auger handle. I believe it may be the auger impeller brake. thanks.


Follow-Up Postings:

 o
RE: Craftsman Dual Stage Snowthrower Auger noise

  • Posted by baymee LehighValleyPA (My Page) on
    Sat, Dec 7, 13 at 7:09

It probably is the brake. Does the idler pulley move smoothly?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tool Shed Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here