Return to the Tractors Forum | Post a Follow-Up

 o
john deere with 17 hp kawasaki no spark

Posted by jdisp texas (My Page) on
Sun, Mar 7, 10 at 9:38

A guy brought me a john deere gt275. He says had no spark he replaced the coil and carb solenoid. Still would not start. I removed shroud and disconnected kill wire and still no spark. Is it possble he got a bad coil?


Follow-Up Postings:

 o
RE: john deere with 17 hp kawasaki no spark

Does your model have an external igniter? If so, you still need the wire to head to the coil and you would need to unhook the kill wire and or oil pressure switch wire further down the line. Last summer I had to replace a coil on one of these and there was a bulletin or something special anyways with the coil. You may want to verify the right coil was purchased. These very seldom fail in my world though.


 o
RE: john deere with 17 hp kawasaki no spark

thanks for the response tomplum, i don't think it has an igniter, but it does have an oil switch. would the igniter be mounted on the shroud? if so, no, only thing there is fuel pump


 o
RE: john deere with 17 hp kawasaki no spark

The parts diagram shows the simple igniter like the singles have, but I've never replaced one. I don't know what percentage of them have them or not. IE an FC420 most had external igniters, some did not. In fact, the coil I put on last year was replaced because the old one was damaged (basket case) The parts listing shows 2 different coils too.
Here is a link for the service manual that may help. http://www3.kawpowr.com/enginesecure/ServiceManuals/FC290V.pdf

Here is a link that might be useful: deere parts


 o
RE: john deere with 17 hp kawasaki no spark

I think they had ignitors through the 1997 model year...not sure exactly. But if you had a " separate ignitor" igniton and you put an "integral ignitor" coil on there it won't work. Flywheels are different.

Given that you've unplugged the kill wire and still nothing, it almost has to be the coil...or the wrong coil (my bet).


 o
RE: john deere with 17 hp kawasaki no spark

hey guys, thanks for the input. just to let you know, i found a kawasaki cadaver and swapped coils and it started right up. must have got a bad coil off the shelf. i'll go tomorrow and get the new one


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here