Return to the Tractors Forum | Post a Follow-Up

 o
Ride on lawn mower

Posted by Jatz123 none (My Page) on
Fri, Apr 26, 13 at 2:42

I recently bought a second hand White LT-12 ride on (12.5 hp Briggs and Stratton I/C motor). It worked fine until we ran over a small bush (hidden in the long grass). The engine stalled.

It started up again easy enough, but couldn't get it into gear so turned it off. After that it wouldn't even turn over.

There's either just a clicking sound from the ignition unit when we turn the ignition or sometimes a whiring sound from the unit that all the safety shut of wires (ie seat, cutting deck etc) run into.

I checked the blades, spindle etc and all looks fine. The original battery was a bit old so I replaced that too. Still no luck. Also tried to jump start from the car without success.

All help is most appreciated


Follow-Up Postings:

 o
RE: Ride on lawn mower

Did you replace the starter solenoid? Try cleaning the spots where the negative cable attaches to the frame of the machine. Did you connect the negative post cable to the frame, or make sure there is no rust on that end. Did you connect the battery, negative (-) to the cable that grounds on the frame, and the (+) cable to the solenoid terminal. Try using jumper cables from a car battery, connecting the ground cable to the engine block of the tractor, and the other cable to the tractor starter post, thence the other end to the car battery. It should crank.
I have had to replace the starter solenoid on some tractors. They get a lot of use, with the frequent starting and stopping. (Thanks to the safety guru's!)


 o
RE: Ride on lawn mower

Thanks rustyj14. I checked the connections were tight but did not clean them. I'll give that a go and check the solenoid. thanks.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here