Return to the Tractors Forum | Post a Follow-Up

 o
Poulan Pro Hydro Trans

Posted by hrldking Texas (My Page) on
Tue, May 22, 07 at 15:42

I have a Poulan Pro 18.5 42" rider. the hydrostatic transmisson is not working. I will go in reverse just fine but when I try to make it go forward it jumps and jerks the finally quits and seems to start slipping and going nowhere.
the hydro is a Peerless H-200-006A, with a 794788 hydro-module. Can anyone tell me where to go from here. Change oil in the pump? Check the tranny for busted or stripped gears? HELP!!!!!!!!!!!!!!!!!! hk


Follow-Up Postings:

 o
RE: Poulan Pro Hydro Trans

You need to take in to a warranty repair Dealer. He can
fix the problem by installing a neutral lock out repair
kit, part# 799032. This is a commonly found problem on the
2000-006A hydro. This part is inside the differential side
of the unit. The pump module (794788) is probably OK.
Nonetheless....Tecumseh/Peerless WILL WARRANTY this for you, as they are VERY FAMILIAR with the problem.

T-Man


 o
RE: Poulan Pro Hydro Trans

Well tecumcman, I guess I am in a pickle here. The closest Premiere Dealer with a Tecumseh Master Technician is over 200 miles from me. I have the repair manual but it says nothing about a neutral lock out, and I can not find a parts dealer that I can order that part # from. Thanks anyway, I'll just have to figure something else out...hrldking.


 o
RE: Poulan Pro Hydro Trans

Tecumcman, I have found someone that has the part. Can you tell me if it is difficult to install. I am a fair mechanic, do you know if there are any kind of instructions that come with that part. Like I said in my prevous post that the closest dealer is over two hundred miles from me and they are six weeks in the rears on repairs. I can order the kit for 16.00 I just need somekind of directions to put it in.......thanks........hk


 o
RE: Poulan Pro Hydro Trans

I'm having the same issues and was wondering if you found the instructions to install the kit? Thanks....


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here