Return to the Tractors Forum | Post a Follow-Up

 o
Craftsman 24hp briggs runs rough

Posted by wwb00 CT (My Page) on
Sat, Jul 3, 10 at 15:28

Hi all, Have gone thru alot of posts similar but this maybe different. YTS4000 tractor has only 14 hours on it. just over one year old out of warranty. Loved the smoothness and power of these motors before, but this ones not right. Always felt a bit off but mostly with blades engaged. It just started running rough with stumbles and backfires at governed engine speed, no different fuel or damage noted. model 445677. Checked valves, changed plugs and fuel filter, solenoid clicks on, fuel flow and cap seem ok, but 14 hours??


Follow-Up Postings:

 o
RE: Craftsman 24hp briggs runs rough

remove/clean carb (trash/water/etc.) use carb rebuild kit. let carb soak in carb cleaner overnite. clean all passageways with thin stiff copper wire. blow clean with compressed air.

check all fuel lines for cracked/deteriorated. install/use inline fuel shutoff valve if a fuel gravity feed setup. drain/flush all fuel with fresh.


 o
RE: Craftsman 24hp briggs runs rough

Well, read my paperwork and there is a warranty for 2 years, but I find authorized service location. Gonna change gas first then follow up on that.


 o
RE: Craftsman 24hp briggs runs rough

You are correct that engine should be warrantied for 2 years. But, there maybe a pickup and return fee it you can't get it to the dealer. Also, make sure all the filters are clean, plugs are clean, If not they will probably say the rough running maybe contributed to that and that may not be under warranty, thus running up the tab? I know you said 14 hours on the engine, but in extreme conditions warrant a 10 hour check of filters.


 o
RE: Craftsman 24hp briggs runs rough

Today I drained gas and ran it through my generator which uses a 19hp version of the v-twin, even though that engine is 20 years old I couldn't help but notice how much smoother it ran. I then put a gallon of fresh 93 octane in the tractor, still the same, got to be vacuum leak or broken valve spring or something. Very leery of how warranty work will be handled. Will return to post results, meanwhile the grass still grows!


 o
RE: Craftsman 24hp briggs runs rough

Well, if anyone is interested, got tractor back yesterday, 3 weeks! And it was....carburetor! Seems ok, we'll see. TTFN


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here