Return to the Tractors Forum | Post a Follow-Up

 o
Blades won't engage: Ariens 17.5 Model # 960160027. 5 months old.

Posted by TexasLawn102 Central (My Page) on
Sun, Jul 6, 14 at 17:08

Just bought this bad boy 5 months ago and all of a sudden the blades don't engage when I 'pull up' the clutch to engage.

Turns on in a snap, I can drive it.

Engine sound does not change when I try to engage.

42 in. 17.5 HP Briggs & Stratton 6-Speed

Belt is pretty new, I've used the tractor about 10 times.

Ideas?

Thanks!


Follow-Up Postings:

 o
RE: Blades won't engage: Ariens 17.5 Model # 960160027. 5 months

Best guess- the belt rolled off one of the deck pulleys.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here