Return to the Tractors Forum | Post a Follow-Up

 o
Mower gets sluggish when blades are engaged

Posted by Adaml961 10 (My Page) on
Sun, Jul 6, 14 at 17:29

This has me stumped. The mower will cut fine for about 30 minutes, then everything slows a little, blades and engine. If I let it sit and cool off, it will run fine for about 30 minutes and will start doing the same thing.

Anyone know what may be causing this?


Follow-Up Postings:

 o
RE: Mower gets sluggish when blades are engaged

Could be a couple things-
Fuel filter is slightly clogged allowing the carb bowl to very slowly run out of fuel.
Coil is heat sensitive and starts to lose spark when hot.(clean cooling fins)

You might state what this is on.


 o
RE: Mower gets sluggish when blades are engaged

F525 with 18hp Kawasaki.


 o
RE: Mower gets sluggish when blades are engaged

I should have mentioned that when the blades are turned off the mower runs fine. It gets sluggish when the blades are turned on after the mower has been running a while.


 o
RE: Mower gets sluggish when blades are engaged

You could have fun with this one. The assumption is that this is engine related. Like all assumptions... It is best to start simple, thorough and cheap on a problem like this. If you haven't started w/ the basics- new spark plug, fuel filter, dropping the carb bowl at least and give a clean and inspect etc now would be a good time. Ignition igniters are famous for creating hot restart issues, but a loss of power- I'd not had myself. Check valves in these old metal fuel pumps can start to falter anytime. Cleaning the cooling fins is a real good idea as Bill indicated as well. Inspect closely for signs of head gasket leakage.


 o
RE: Mower gets sluggish when blades are engaged

After checking the engine issues already mentioned, check the condition of the blade spindles and the idlers on the deck. Looking for problems with bearings.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here