Return to the Tractors Forum | Post a Follow-Up

 o
Transaxle Problem

Posted by robman (My Page) on
Mon, Jul 19, 10 at 18:40

I am looking for info from anyone who might be able to help. I have a Husqvarna YTH-2148 with a LTH-2000 transaxle. The machine started showing problems when the forward and backwards hydros started spiking whenever they were engaged. After an hour or so the tractor would throw itself in reverse while it was going forward. The actual shifter would never move, it just seemed to do whatever it wanted. Finally it would only go forward for 10 or so feet then you had to go backwards for 50 or so feet before it would go forward again. Very weird to say the least. Does anyone have any input on what might be wrong with that transaxle? Is it possible to repair that particular model? Any input on where I could find one cheaper than retail?
Thanks for any help you can give. Robert


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here