Return to the Tractors Forum | Post a Follow-Up

 o
Electrical problem with Craftsman tractor

Posted by JoeZZ none (My Page) on
Mon, Jul 15, 13 at 20:40

I have a Craftman lawn tractor model number 917.287360, engine model number SV610-0021 (kohler 21 HP).
I had in issue starting my tractor that caused me to unplug the seat, brake and blade safety switches. I also removed and tested the solenoid and starter. I resolved one issue (with the help of the forum) but created another. The tractor will now start and run until I remove my foot from the brake, then it will stall. I unplugged the brake safety switch, jumped the white wires (to solenoid) and left the black wires (ground I believe ) open. The tractor now starts and runs fine, however, when I try to engage the blade, it stalls. Also the seat safety switch no longer shuts the engine off when I get off the seat. I tested the seat safety switch with a new switch and it still does not shut off the engine. My guess is I can unplug to blade switch and jump it, but I want to get the safety switches working.
Anyone have any ideas where to look next?


Follow-Up Postings:

 o
RE: Electrical problem with Craftsman tractor

Deleted since you never gave results to your original problem 2 days ago!

This post was edited by bill_kapaun on Mon, Jul 15, 13 at 21:01


 o
RE: Electrical problem with Craftsman tractor

I posted this note with my orginal posting - Intermittent starting problem on Craftman Tractor (99% of the time) - if this needs to be deleted now, how do I do that


 o
RE: Electrical problem with Craftsman tractor

Basically, just don't add any more posts to this thread.
You should just stay with 1 thread until that issue is resolved.
Putting multiple threads out on the exact same issue only makes it difficult to maintain a sense of continuity in the discussion.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here