Return to the Tractors Forum | Post a Follow-Up

 o
jihn deere 425 pto problem

Posted by jimmy45 none nc (My Page) on
Sun, Aug 17, 14 at 9:13

my 425 runs great,but when you engage the pto the mower is turning real slow like its in a bind.checked gear box,blade quill assy,all good.turn off the mower runs and drives fine.anyone have a clue what the problem is?


Follow-Up Postings:

 o
RE: jihn deere 425 pto problem

Check driveshaft, carrier bearings, and u-joint(s)


 o
RE: jihn deere 425 pto problem

I suppose the clutch may be worn. It would be more likely that the secondary drive belt has a problem or you lost a tension spring.


 o
RE: john deere 425 pto problem

I can't get the PTO on my 425 John Deere to shut off, Any ideas of what I can do to fix this?


 o
RE: jihn deere 425 pto problem

You will have to verify if there is power to your clutch in the off position first to determine if it is electrical or something physical w/ the clutch.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here