Return to the Tractors Forum | Post a Follow-Up

 o
Wheel Horse 310-8

Posted by Vzich none (My Page) on
Sat, Nov 24, 12 at 12:55

My good ole Wheel Horse is in need of a part. The tractor won't start. I charged the battery since it had been sitting, and all I get is a rapid tick, tick, tick sound apparently coming from the starter? Thought perhaps it could also be a solinoid? Any thoughts on: (1) How I can confirm (2) a good place to buy the part(s)


Follow-Up Postings:

 o
RE: Wheel Horse 310-8

Clean/tighten connections in the cranking circuit. This includes engine mounting bolts etc.

Get the battery load tested at a place like Autozone etc.
If the battery is good (doesn't sound like it) we can go from there.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here