Return to the Tractors Forum | Post a Follow-Up

 o
john deer l120 hard to start

Posted by eddier51 8 (My Page) on
Fri, Nov 16, 12 at 18:38

My John Deer l120 is hard to start,put in a new battery but it still acts like the battery is weak and will barely turn over especially if it is cold outside.I usually hook up the battery charger to it,but here lately that does'nt even work.Help Please!


Follow-Up Postings:

 o
RE: john deer l120 hard to start

I assume that's an L120?

Briggs OHV engines need to have the valves properly adjusted for the compression release to function properly.

There are numerous threads on that exact problem if you just scroll down a few threads/pages.

Walt Conner has a procedure that HE will send you if YOU email him, telling him what you want.
Look for his address in the mentioned threads.


 o
RE: john deer l120 hard to start

Thanks Bill appreciate the help


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tractors Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here