Return to the Trees Forum | Post a Follow-Up

 o
Dying Leyland, HELP Needed, please!

Posted by BermudaBeautiful Long Island, NY (My Page) on
Tue, Apr 17, 12 at 8:49

I bought a 10ft cypress 3 weeks ago and did everything I read to do. Dug the hole twice the size of the root ball,backfilled it, put holly tone in the hole, watered thoroughly, put mulch around the base, etc. Now, as you can see from the pictures it is wiltering. I dont understand why because it gets nearly 6hrs of sun every day, the spot is well drained and every 5 days i am soaking it for 10 minutes with water. It has been warm here with no rain. Weird thing is that the two green giants that I planted next to it are doing fine. What could possibly be wrong? Too much water, too little, not enough air for the roots, bad soil? Please help, I am very upset about losing this tree.

Image link: Dying Leyland, HELP Needed, please! (29 k)


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Trees Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here