Return to the Trees Forum | Post a Follow-Up

 o
Early spring here...

Posted by lou_midlothian_tx z8 DFW, Tx (My Page) on
Sat, Feb 25, 12 at 12:14

Bradford trees are almost full of leaves already. One thing I've noticed is that they didn't bloom very much. Do they need certain numbers of chilling hours to bloom?

Also, I noticed that my Shantung Maple 'Skinny Dragon' is about to bloom. I don't recall any Shantung maples doing that this early before. It has been a rather mild winter with above average rainfall which was much needed for Texas.


Follow-Up Postings:

 o
RE: Early spring here...

I would guess, since the flower buds are formed during the prior growing season, that stress on the trees last summer from the extreme heat and drought you had in Texas was probably responsible for the poor floral display you observed.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Trees Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here