Return to the Trees Forum | Post a Follow-Up

 o
Arborvitae care for winter

Posted by Renee369 New York (My Page) on
Thu, Sep 26, 13 at 10:02

I just had arborvitae trees planted in May. They were about 5 feet tall and took well and have grown. My concern is that in the last 2 weeks they all are turning really rusty brown like they are dying. Is that really normal for them? The landscape company I purchased them from said it is when i brought pictures to them to see....they didn't install them so they now are saying they will not warrantee them and I'm over reacting! To me they just look like they are over 1/2 dead and I'm concerned? It was a huge investment. Any suggestions? Am I really worrying for nothing as this "IS" normal for them this time of year?


Follow-Up Postings:

 o
RE: Arborvitae care for winter

if you took them a pic

how about posting us a pic

ken


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Trees Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here